Advance Java Beginning

Is every Advnace java program need to be run on Apache tomcat?