OpenliteSpeed Server (LOMP) server Setup

Hello ,
This is Aaditya, I am updating a multi-site WordPress(WP) setup and migrating it to OLS (Openlitespeed server) from Apache.
Currently, I am facing issues in PHP compatibility, some WP plugins use 7.4 as base PHP and some use 7.2.
Since most of the plugins are business crucial, is there any way where we can give PHP 7.2 and 8.0.0 and all the versions in between by these plugins ?
How to ensure that all the compatibility are matched by installing all versions of PHP old and new ones to come.