Plugin Compability

If Plugin is say “Untested with your version of WordPress” is that ok to add it we skip it ?